Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a2
    • Component/s: Installation system
    • Labels:
      None
    • Environment:
      PHP Version 5.5.3, MySQL 5.0.11

      Description

      I get this message if I want to update from 3.0.12 to 3.1:

      Your installed version is 3.1.0-a1 and the update file is for updating phpBB 3.0.12 to 3.1.0-a1.

      I could upgrade, but my forum doesn't show up.

        Activity

        Hide
        bantu Andreas Fischer added a comment -

        What does "my forum doesn't show up" mean? If you only get a white page, check the error log of your webserver.

        Show
        bantu Andreas Fischer added a comment - What does "my forum doesn't show up" mean? If you only get a white page, check the error log of your webserver.
        Hide
        bantu Andreas Fischer added a comment -

        Are you upgrading to 3.1.0-a1 or 3.1.0-dev (i.e. git version)?

        Show
        bantu Andreas Fischer added a comment - Are you upgrading to 3.1.0-a1 or 3.1.0-dev (i.e. git version)?
        Hide
        panhead panhead added a comment -

        I think I made a mistake and used the wrong update file (yes, stupid....). It's a local installation, so no disaster, but would it be possible to go back to 3.1.0-a1?

        Show
        panhead panhead added a comment - I think I made a mistake and used the wrong update file (yes, stupid....). It's a local installation, so no disaster, but would it be possible to go back to 3.1.0-a1?
        Hide
        panhead panhead added a comment -

        As it probably is my fault, it's probably not a bug.

        Show
        panhead panhead added a comment - As it probably is my fault, it's probably not a bug.
        Hide
        ktulu ktulu added a comment -

        I had this same issue. I downloaded phpBB-3.0.12_to_3.1.0-a1.zip. After it checked files during the upgrade process, I was prompted to download update_3.0.12_to_3.1.0-a1.zip. I installed the files and after the database update I got the same error. My logs generate the following when I try to open the board:

        PHP Fatal error: Uncaught exception 'Symfony\\Component\\DependencyInjection\\Exception
        InvalidArgumentException' with message '"'\\\\phpbb\\\\cache\\\\driver\\\\file'" is not a valid class name for the "cache.driver" service.' in /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php:333\nStack trace:\n#0 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php(581): Symfony\\Component\\DependencyInjection\\Dumper
        PhpDumper->addServiceInstance('cache.driver', Object(Symfony\\Component\\DependencyInjection\\Definition))\n#1 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php(608): Symfony\\Component\\DependencyInjection\\Dumper
        PhpDumper->addService('cache.driver', Object(Symfony\\Component\\DependencyInjection\\Definition))\n#2 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper in /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php on line 333

        Show
        ktulu ktulu added a comment - I had this same issue. I downloaded phpBB-3.0.12_to_3.1.0-a1.zip. After it checked files during the upgrade process, I was prompted to download update_3.0.12_to_3.1.0-a1.zip. I installed the files and after the database update I got the same error. My logs generate the following when I try to open the board: PHP Fatal error: Uncaught exception 'Symfony\\Component\\DependencyInjection\\Exception InvalidArgumentException' with message '"'\\\\phpbb\\\\cache\\\\driver\\\\file'" is not a valid class name for the "cache.driver" service.' in /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php:333\nStack trace:\n#0 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php(581): Symfony\\Component\\DependencyInjection\\Dumper PhpDumper->addServiceInstance('cache.driver', Object(Symfony\\Component\\DependencyInjection\\Definition))\n#1 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php(608): Symfony\\Component\\DependencyInjection\\Dumper PhpDumper->addService('cache.driver', Object(Symfony\\Component\\DependencyInjection\\Definition))\n#2 /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper in /forum/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php on line 333
        Hide
        ktulu ktulu added a comment -

        Changing the version number in the DB corrects the "your installed version" error, but not the error from my logs.

        Show
        ktulu ktulu added a comment - Changing the version number in the DB corrects the "your installed version" error, but not the error from my logs.
        Hide
        EXreaction EXreaction [X] (Inactive) added a comment -

        We didn't see this error earlier I guess because it requires DEBUG not to be enabled to get the error. Merged the PR and should be fixed now.

        Show
        EXreaction EXreaction [X] (Inactive) added a comment - We didn't see this error earlier I guess because it requires DEBUG not to be enabled to get the error. Merged the PR and should be fixed now.

          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            panhead panhead
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development