Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11866

"You have specified an invalid dbms driver" Error with config sample

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Labels:
      None
    • Environment:
      Apache/2.4.4 (Win32) OpenSSL/0.9.8y PHP/5.4.16
      MySQL(i) 5.5.32

      XAMPP 1.8.2

      Description

      Fatal error: Uncaught exception 'RuntimeException' with message 'You have specified an invalid dbms driver: phpbb_db_driver_mysqli' in C:\xampp\htdocs\1057\includes\functions.php:5713 Stack trace: #0 C:\xampp\htdocs\1057\includes\functions_container.php(34): phpbb_convert_30_dbms_to_31('phpbb_db_driver...') #1 C:\xampp\htdocs\1057\includes\functions_container.php(67): phpbb_bootstrap_db_connection('./config.php') #2 C:\xampp\htdocs\1057\includes\functions_container.php(258): phpbb_bootstrap_enabled_exts('./config.php', './') #3 C:\xampp\htdocs\1057\common.php(106): phpbb_create_default_container('./', 'php') #4 C:\xampp\htdocs\1057\index.php(19): include('C:\xampp\htdocs...') #5

      {main}

      thrown in C:\xampp\htdocs\1057\includes\functions.php on line 5713

        Issue Links

          Activity

          Hide
          nickvergessen Joas Schilling added a comment - - edited

          You need to manually change your config.php
          either to mysqli or

          phpbb\\db\\driver\\mysqli

          same for acm_type to file or

          phpbb\\cache\\driver\\file

          Show
          nickvergessen Joas Schilling added a comment - - edited You need to manually change your config.php either to mysqli or phpbb\\db\\driver\\mysqli same for acm_type to file or phpbb\\cache\\driver\\file
          Hide
          nickvergessen Joas Schilling added a comment -

          Just noticed, this should be changed for the RUNNING_TESTS.md

          Show
          nickvergessen Joas Schilling added a comment - Just noticed, this should be changed for the RUNNING_TESTS.md
          Hide
          wintstar wintstar added a comment -

          Work, but would have to be changed automatically when you update from 3.0.11 to 3.1.0. Thanks nickvergessen. Can closed.

          // Do not change anything in this file!
          $dbms = 'phpbb\\db\\driver
          mysqli';
          $dbhost = 'localhost';
          $dbport = '';
          $dbname = '####';
          $dbuser = 'root';
          $dbpasswd = '######';
          $table_prefix = 'phpbb_';
          $adm_relative_path = 'adm/';
          $acm_type = 'phpbb\\cache\\driver
          file';

          @define('PHPBB_INSTALLED', true);
          // @define('DEBUG', true);

          Show
          wintstar wintstar added a comment - Work, but would have to be changed automatically when you update from 3.0.11 to 3.1.0. Thanks nickvergessen. Can closed. // Do not change anything in this file! $dbms = 'phpbb\\db\\driver mysqli'; $dbhost = 'localhost'; $dbport = ''; $dbname = '####'; $dbuser = 'root'; $dbpasswd = '######'; $table_prefix = 'phpbb_'; $adm_relative_path = 'adm/'; $acm_type = 'phpbb\\cache\\driver file'; @define('PHPBB_INSTALLED', true); // @define('DEBUG', true);
          Hide
          nickvergessen Joas Schilling added a comment -

          We can not update the file, thats why mysqli (3.0 version) will continue to work.

          Show
          nickvergessen Joas Schilling added a comment - We can not update the file, thats why mysqli (3.0 version) will continue to work.
          Hide
          bantu Andreas Fischer added a comment -

          There has not been any 3.1 release. Breaking underscore is fine with me.

          Show
          bantu Andreas Fischer added a comment - There has not been any 3.1 release. Breaking underscore is fine with me.
          Hide
          wintstar wintstar added a comment -

          (There has not been any 3.1 release. Breaking underscore is fine with me.)
          I am aware that it is not the release. Just wanted to point out.

          Show
          wintstar wintstar added a comment - (There has not been any 3.1 release. Breaking underscore is fine with me.) I am aware that it is not the release. Just wanted to point out.

            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              wintstar wintstar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development