Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11863

User registration settings show incorrectly as disabled when board-wide emails are disabled

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.11
    • Fix Version/s: 3.1.2-RC1
    • Component/s: Authentication
    • Labels:
      None
    • Environment:
      PHP 5.2.17, MySql: 5.5.33, browser: all (although tested in Google Chrome 29.0.1547.76 m)

      Description

      Under "User registration settings" my account activation is usually set to "by admin". However, when I disable board-wide emails the account activation shows as "Disable registration". However, anyone is then allowed to register without any authentication.

      I would have thought that this should show as "No activation (instant access)" rather than "Disable registration".

      This has lead me to believe that the registration is automatically disabled when I disable board-wide emails. However this isn't the case as anyone can then register instantly and post to my forum, when I switch off board-wide emails.

      This has led to spammers registering and posting on my forums while I thought that registration was disabled.

        Attachments

          Activity

            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              Rob Leeson Rob Leeson [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: