Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11769

Wrong poster in subscription email when poster is using the Quote button

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.12-RC2
    • Fix Version/s: 3.0.12-RC3
    • Labels:
      None

      Description

      Subscription emails for new replies to topics in a forum that you've subscribed to show the wrong poster for the new reply OR it is sending me an email for my own post:

      You are receiving this notification because you are watching the forum,
      "XYZ Forum" at "phpBB.com". This forum has received a new reply to the
      topic "Topic Name" by MichaelC since your last
      visit. You can use the following link to view the last unread reply, no
      more notifications will be sent until you visit the topic.

        Issue Links

          Activity

          bantu Andreas Fischer added a comment -

          We are unable to reproduce this on phpBB.com

          You are receiving this notification because you are watching the forum,
          "Test Me" at "phpBB.com". This forum has received a new reply to the topic
          "test" by nickvergessen since your last visit. You can use the following
          link to view the last unread reply, no more notifications will be sent
          until you visit the topic.

          You are receiving this notification because you are watching the forum,
          "Test Me" at "phpBB.com". This forum has received a new topic by
          nickvergessen since your last visit, "test". You can use the following link
          to view the forum, no more notifications will be sent until you visit the
          forum.

          You are receiving this notification because you are watching the topic,
          "test" at "phpBB.com". This topic has received a reply by nickvergessen
          since your last visit. You can use the following link to view the replies
          made, no more notifications will be sent until you visit the topic.

          *daniel *daniel added a comment -

          Is this coming from a clean install or upgrade? Also are there any mods installed if it an upgrade?

          nickvergessen Joas Schilling added a comment -

          both was tested on .com itself so of course there are some modifications

          MichaelC Michael Cullum added a comment -

          Slightly bizarre we can't reproduce this despite being on the same site and we know it happened. What do you want to do with this Andreas?

          bantu Andreas Fischer added a comment -

          Just leave it open until we release RC3 or final.

          bantu Andreas Fischer added a comment - - edited

          Caller must (should) be from functions_posting:

          afischer@leonard:/var/www/projects/phpbb3 (prep-release-3.0.12) phpBB $ grep "user_notification" . -Ri
          ./includes/mcp/mcp_queue.php:				user_notification('post', $post_data['topic_title'], $post_data['topic_title'], $post_data['forum_name'], $post_data['forum_id'], $post_data['topic_id'], $post_id);
          ./includes/mcp/mcp_queue.php:				user_notification('reply', $post_data['post_subject'], $post_data['topic_title'], $post_data['forum_name'], $post_data['forum_id'], $post_data['topic_id'], $post_id);
          ./includes/functions_posting.php:function user_notification($mode, $subject, $topic_title, $forum_name, $forum_id, $topic_id, $post_id, $author_name = '')
          ./includes/functions_posting.php:		user_notification($mode, $subject, $data['topic_title'], $data['forum_name'], $data['forum_id'], $data['topic_id'], $data['post_id'], $username);
          

          MichaelC Michael Cullum added a comment -

          This is caused by quoting.


            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              MichaelC Michael Cullum
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development