Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11751

MCP Softdelete Modules missing when updating board

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: Posting
    • Labels:
      None
    • Environment:
      MySQL(i) 5.1.67-log
      PHP Version 5.4.17

      Build 971

      Description

      When you click on the soft-delete symbol there is an error message.

      Module not accessible

      BACKTRACE

      FILE: (not given by php)
      LINE: (not given by php)
      CALL: msg_handler()

      FILE: [ROOT]/includes/functions_module.php
      LINE: 465
      CALL: trigger_error()

      FILE: [ROOT]/mcp.php
      LINE: 237
      CALL: p_master->load_active()

      You can test it here http://test.wintstar.de/viewforum.php?f=7. Click of the green icon.

        Activity

        Hide
        wintstar wintstar added a comment -

        error by click of green icon

        Show
        wintstar wintstar added a comment - error by click of green icon
        Hide
        nickvergessen Joas Schilling added a comment -

        can you copy paste the link?

        Show
        nickvergessen Joas Schilling added a comment - can you copy paste the link?
        Show
        wintstar wintstar added a comment - http://test.wintstar.de/mcp.php?i=queue&mode=deleted_topics&t=7&sid=bc043c2d7671cae0313d9a5650301e7b
        Hide
        wintstar wintstar added a comment -

        Since the error seems to appear only here http://test.wintstar.de/index.php in the forum I have again reinstalled 3.1.0-dev 939 step by step build in English. I deleted each updated with new files that are old except for config.php and the img files and folders. Then I run install / database_update.php out to update the database.
        With Build 942 "Soft delete" was introduced.

        Update to 939 to 942

        New database entries were not created.

        Update 942 to 944

        Updating database to latest stable release

        Database type :: mysqli
        Previous version :: 3.1.0-dev
        Installed Schema: phpbb_db_migration_data_310_notification_options_reconvert
        Installed Data: phpbb_db_migration_data_310_notification_options_reconvert
        Installed Schema: phpbb_db_migration_data_310_softdelete_p1
        Installed Data: phpbb_db_migration_data_310_softdelete_p1
        Installed Schema: phpbb_db_migration_data_310_softdelete_p2
        Installed Data: phpbb_db_migration_data_310_softdelete_p2
        Database updater has completed!

        Update 944 to 946
        New database entries were not created.

        Update 946 to 947
        New database entries were not created.

        Update 947 to 987
        New database entries were not created.

        Database entries can be downloaded here http://test.wintstar.de/viewtopic.php?f=8&t=16&p=61#p61. It would have to be checked the database entries for database_update.php. During the upgrade to the new version some are missing.

        Show
        wintstar wintstar added a comment - Since the error seems to appear only here http://test.wintstar.de/index.php in the forum I have again reinstalled 3.1.0-dev 939 step by step build in English. I deleted each updated with new files that are old except for config.php and the img files and folders. Then I run install / database_update.php out to update the database. With Build 942 "Soft delete" was introduced. Update to 939 to 942 New database entries were not created. Update 942 to 944 Updating database to latest stable release Database type :: mysqli Previous version :: 3.1.0-dev Installed Schema: phpbb_db_migration_data_310_notification_options_reconvert Installed Data: phpbb_db_migration_data_310_notification_options_reconvert Installed Schema: phpbb_db_migration_data_310_softdelete_p1 Installed Data: phpbb_db_migration_data_310_softdelete_p1 Installed Schema: phpbb_db_migration_data_310_softdelete_p2 Installed Data: phpbb_db_migration_data_310_softdelete_p2 Database updater has completed! Update 944 to 946 New database entries were not created. Update 946 to 947 New database entries were not created. Update 947 to 987 New database entries were not created. Database entries can be downloaded here http://test.wintstar.de/viewtopic.php?f=8&t=16&p=61#p61 . It would have to be checked the database entries for database_update.php. During the upgrade to the new version some are missing.
        Hide
        wintstar wintstar added a comment -

        Found errors with nickvergessen. For updates on the latest build in the Moderation queue following modules are not loaded:

        Deleted topics
        Deleted posts

        Show
        wintstar wintstar added a comment - Found errors with nickvergessen. For updates on the latest build in the Moderation queue following modules are not loaded: Deleted topics Deleted posts

          People

          • Assignee:
            nickvergessen Joas Schilling
            Reporter:
            wintstar wintstar
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development