Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11619

get_remote_file() should use HTTP 1.0

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.11, 3.1.0-dev
    • Fix Version/s: 3.0.12-RC1
    • Component/s: None
    • Labels:
      None

      Description

      The get_remote_file() function issues a request using HTTP 1.1, but is not capable of processing some of the features of a 1.1 response, such as a chunked response. We should probably use HTTP 1.0 requests instead.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            bantu Andreas Fischer
            Reporter:
            Noxwizard Patrick Webster
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development