Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11573

Test Suite does not work with MySQL STRICT_TRANS_TABLES (MySQL 5.6)

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: None
    • Labels:
      None
    • Environment:
      mysql-5.6.11-winx64

      Description

      afischer@leonard:/var/www/projects/phpbb3 (develop) $ phpunit
      PHPUnit 3.7.19 by Sebastian Bergmann.
       
      Configuration read from /var/www/projects/phpbb3/phpunit.xml.dist
       
      .................................................I.....SSSS..   61 / 1969 (  3%)
      .....SSSS....................................................  122 / 1969 (  6%)
      .............................................................  183 / 1969 (  9%)
      ..................................F..........................  244 / 1969 ( 12%)
      .............................................................  305 / 1969 ( 15%)
      .............................................................  366 / 1969 ( 18%)
      ...........................................................EE  427 / 1969 ( 21%)
      EEEE.........................................................  488 / 1969 ( 24%)
      .............................................................  549 / 1969 ( 27%)
      .............................................................  610 / 1969 ( 30%)
      .............................................................  671 / 1969 ( 34%)
      .............................................................  732 / 1969 ( 37%)
      .............................................................  793 / 1969 ( 40%)
      .............................................................  854 / 1969 ( 43%)
      .............................................................  915 / 1969 ( 46%)
      .............................................................  976 / 1969 ( 49%)
      ............................................................. 1037 / 1969 ( 52%)
      ............................................................. 1098 / 1969 ( 55%)
      ............................................................. 1159 / 1969 ( 58%)
      ............................................................. 1220 / 1969 ( 61%)
      ............................................................. 1281 / 1969 ( 65%)
      ............................................................. 1342 / 1969 ( 68%)
      ............................................................. 1403 / 1969 ( 71%)
      ............................................................. 1464 / 1969 ( 74%)
      ............................................................. 1525 / 1969 ( 77%)
      ............................................................. 1586 / 1969 ( 80%)
      ............................................................. 1647 / 1969 ( 83%)
      ............................................................. 1708 / 1969 ( 86%)
      ............................................................. 1769 / 1969 ( 89%)
      ............................................................. 1830 / 1969 ( 92%)
      ..EEE................................
       
      Time: 27:08, Memory: 64.25Mb
       
      There were 9 errors:
       
      1) phpbb_functions_style_select_test::test_style_select with data set #0 ('', false, '<option value="1">prosilver</option><option value="2">subsilver2</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      2) phpbb_functions_style_select_test::test_style_select with data set #1 ('', true, '<option value="1">prosilver</option><option value="2">subsilver2</option><option value="3">zoo</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      3) phpbb_functions_style_select_test::test_style_select with data set #2 ('1', false, '<option value="1" selected="selected">prosilver</option><option value="2">subsilver2</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      4) phpbb_functions_style_select_test::test_style_select with data set #3 ('1', true, '<option value="1" selected="selected">prosilver</option><option value="2">subsilver2</option><option value="3">zoo</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      5) phpbb_functions_style_select_test::test_style_select with data set #4 ('3', false, '<option value="1">prosilver</option><option value="2">subsilver2</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      6) phpbb_functions_style_select_test::test_style_select with data set #5 ('3', true, '<option value="1">prosilver</option><option value="2">subsilver2</option><option value="3" selected="selected">zoo</option>')
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_styles`
                      (`style_id`, `style_name`, `style_active`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => prosilver
          [2] => 1
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'style_parent_tree' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      7) phpbb_user_loader_test::test_load_get
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_users`
                      (`user_id`, `username`, `username_clean`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => Guest
          [2] => guest
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'user_permissions' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /var/www/projects/phpbb3/tests/user/user_loader_test.php:24
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      8) phpbb_user_loader_test::test_load_get_unloaded
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_users`
                      (`user_id`, `username`, `username_clean`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => Guest
          [2] => guest
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'user_permissions' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /var/www/projects/phpbb3/tests/user/user_loader_test.php:24
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      9) phpbb_user_loader_test::test_load_user_by_username
      PHPUnit_Extensions_Database_Operation_Exception: COMPOSITE[INSERT] operation failed on query: 
                      INSERT INTO `phpbb_users`
                      (`user_id`, `username`, `username_clean`)
                      VALUES
                      (?, ?, ?)
                   using args: Array
      (
          [0] => 1
          [1] => Guest
          [2] => guest
      )
       [SQLSTATE[HY000]: General error: 1364 Field 'user_permissions' doesn't have a default value]
       
      /var/www/projects/phpbb3/tests/test_framework/phpbb_database_test_case.php:35
      /var/www/projects/phpbb3/tests/user/user_loader_test.php:24
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      --
       
       
      There was 1 failure:
       
      1) phpbb_dbal_order_lower_test::test_order_lower
      Failed asserting that two arrays are equal.
      --- Expected
      +++ Actual
      @@ @@
       Array (
           0 => Array (...)
           1 => Array (
      -        'style_id' => 3
      -        'style_name' => 'Prosilver1'
      +        'style_id' => '2'
      +        'style_name' => 'prosilver2'
               'style_copyright' => '&copy; phpBB Group'
      -        'style_active' => 0
      -        'style_path' => 'prosilver1'
      +        'style_active' => '0'
      +        'style_path' => 'prosilver2'
               'bbcode_bitfield' => 'kNg='
      -        'style_parent_id' => 1
      -        'style_parent_tree' => 'prosilver'
      +        'style_parent_id' => '0'
      +        'style_parent_tree' => ''
           )
           2 => Array (
      -        'style_id' => 2
      -        'style_name' => 'prosilver2'
      +        'style_id' => '3'
      +        'style_name' => 'Prosilver1'
               'style_copyright' => '&copy; phpBB Group'
      -        'style_active' => 0
      -        'style_path' => 'prosilver2'
      +        'style_active' => '0'
      +        'style_path' => 'prosilver1'
               'bbcode_bitfield' => 'kNg='
      -        'style_parent_id' => 0
      -        'style_parent_tree' => ''
      +        'style_parent_id' => '1'
      +        'style_parent_tree' => 'prosilver'
           )
       )
       
      /var/www/projects/phpbb3/tests/dbal/order_lower_test.php:63
      /usr/share/php/PHPUnit/TextUI/Command.php:176
      /usr/share/php/PHPUnit/TextUI/Command.php:129
       
      FAILURES!
      Tests: 1861, Assertions: 13260, Failures: 1, Errors: 9, Incomplete: 1, Skipped: 8.
      

        Issue Links

          Activity

          bantu Andreas Fischer added a comment -

          SELECT @ @session.sql_mode AS sql_mode

          returns

          STRICT_TRANS_TABLES,NO_ENGINE_SUBSTITUTION

          which pretty much means this is caused by STRICT_TRANS_TABLES.

          phpBB sets STRICT_TRANS_TABLES, but the test suite does not. The test suite should be at least as strict as phpBB.


            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              bantu Andreas Fischer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development