Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11551

ACP System tab errors: [phpBB Debug] PHP Notice: in file [ROOT]/includes/acp/acp_update.php on line 49: Undefined offset: 1

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: None
    • Labels:
      None

      Description

      When going to the system tab, the error in the title is at the top of the page.

      Note that this may be simply due to misconfiguration on my new PC. I have not had a chance to test on another PC.

      After doing some debug, is the line that is supposed to get the URL of the release announcement for update notices. The $info variable is empty, so $info[1], which is supposed to be the URL, is undefined.

        Activity

        imkingdavid David King added a comment -

        I propose changing

        if ($info === false)


        to

        if (empty($info))

        bantu Andreas Fischer added a comment -

        This is likely to also affect 3.0.x.

        imkingdavid David King added a comment -

        The version check in the main ACP page seems to work.

        I have isolate the issue to get_remote_file(). Outside of

        		while (!@feof($fsock))

        I see the output of some echo statements I placed in there for debug. Inside, I see nothing. I tried to remove the @ and turn on error reporting to E_ALL but it didn't output an error.

        imkingdavid David King added a comment -

        area51 does not have this issue, but I'm not sure how recently it was updated to develop.

        bantu Andreas Fischer added a comment -

        I am unable to reproduce the error message, but additional checking seems to be useful.

        imkingdavid David King added a comment -

        Because it appears to be a misconfiguration on my end that is preventing the get_remote_file() function from contacting the remote server, I moved this to Major instead of blocker.

        I am submitting a patch that replaces two instances of

        if ($info === false)

        with

        if (empty($info))

        so that an ugly debug error is no longer shown; instead a prettier failure that doesn't keep admins from using the page.


          People

          • Assignee:
            imkingdavid David King
            Reporter:
            imkingdavid David King
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development