Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11538

SQL error on UCP groups manage page caused by setting color to 7 characters long string

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0.11, 3.1.0-dev
    • Fix Version/s: 3.0.12-RC1
    • Labels:
      None

      Description

      Someone very crazy has allowed a 7 character long string for the group color on the UCP group manage page. Due to the fact that MySQL (and possibly other databases as well) only expect a 6 character long string a SQL error is thrown upon submitting which complains about the data being too long for the column (duh, has anyone ever seen a 7 character color?).

        Issue Links

          Activity

          RMcGirr83 Rich McGirr added a comment -

          Can't add more than 6 due to maxlength and when changing that using firebug can add 7 but tosses a trigger error stating invalid hex code


            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              Marc Marc
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development