Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11535

ACP und UCP avatar groups settings do not display an error upon submitting incorrect data

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Labels:
      None

      Description

      This issue has been encountered upon adding the new functional tests for the new avatar system.

      While submitting incorrect data should cause us to see an error message, this currently does not happen. The issue is caused by the fact, that the avatar_error array is not merged into the error array until after the code passage that applies the newly added settings is executed.
      However, due to the way errors are handled in the avatar code itself, the incorrect avatar settings will not be saved.

        Activity

        bantu Andreas Fischer added a comment -

        Just noticed this bug as well.


          People

          • Assignee:
            bantu Andreas Fischer
            Reporter:
            Marc Marc
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development