Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11532

acp_users_overview.html autocompletes "confirm email" and "password" fields in chrome

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.11
    • Fix Version/s: 3.1.5-RC1
    • Labels:
      None

      Description

      When an admin uses Google Chrome to open up the acp overview page for a user, the page opens with the confirm email and password fields autocompleted, even though adm/styles/acp_users_overview.html has 'autocomplete="off"' in those fields. This does not happen in other browsers I've tried.

      When I googled this issue, I found that chrome now ignores 'autocomplete="off"' unless it appears in the <form> tag. So I tried the following and it seems to fix things:

      OPEN
      adm/acp_users_overview.html
       
      FIND
      <form id="user_overview" method="post" action="{U_ACTION}">
       
      REPLACE WITH
      <form id="user_overview" method="post" action="{U_ACTION}" autocomplete="off">
      

      If this is accepted as a fix, you would presumably delete 'autocomplete="off" in the other places it appears in that file.

        Activity

        asinshesq asinshesq added a comment -

        The same issue comes up twice in adm/style/acp_forums.html and once in adm/index.php (easy to address the same way as above in acp_forums.html but trickier in adm/index.php).

        Marc Marc added a comment -

        Seems to have been caused by a bug in Chrome and can no longer be reproduced.


          People

          • Assignee:
            Marc Marc
            Reporter:
            asinshesq asinshesq
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development