Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11363

Migrations module tool does not load info files from extensions

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: Other
    • Labels:
      None

      Description

      Please see the following post for full description: http://area51.phpbb.com/phpBB/viewtopic.php?f=108&p=251321#p251319

        Issue Links

          Activity

          Hide
          EXreaction EXreaction [X] (Inactive) added a comment -

          Blitze, would you be able to test your code on my branch in the pull request?

          https://github.com/phpbb/phpbb3/pull/1252

          Show
          EXreaction EXreaction [X] (Inactive) added a comment - Blitze, would you be able to test your code on my branch in the pull request? https://github.com/phpbb/phpbb3/pull/1252
          Hide
          Blitze Blitze added a comment -

          I tested it and it works really well both for adding new modules and removing them, although there it's a problem removing module categories created by extensions but I'll test further and post a separate ticket for that.

          Thanks

          Show
          Blitze Blitze added a comment - I tested it and it works really well both for adding new modules and removing them, although there it's a problem removing module categories created by extensions but I'll test further and post a separate ticket for that. Thanks
          Hide
          EXreaction EXreaction [X] (Inactive) added a comment -

          Thank you for testing it.

          Show
          EXreaction EXreaction [X] (Inactive) added a comment - Thank you for testing it.
          Hide
          EXreaction EXreaction [X] (Inactive) added a comment -

          Blitze, are you sure this works? I'm pretty sure it doesn't because the finder doesn't search for files in extensions that are not enabled yet (I'm testing it now and it's not working correctly for me).

          Show
          EXreaction EXreaction [X] (Inactive) added a comment - Blitze, are you sure this works? I'm pretty sure it doesn't because the finder doesn't search for files in extensions that are not enabled yet (I'm testing it now and it's not working correctly for me).
          Hide
          Blitze Blitze added a comment -

          It worked when I tried it. I was using an enabled extension. What I tested was the code you merged on 2/28. I think the changes you merged today to migrstions/tools/module.php and to acp_module.php broke it. It doesn't work for me either.

          Show
          Blitze Blitze added a comment - It worked when I tried it. I was using an enabled extension. What I tested was the code you merged on 2/28. I think the changes you merged today to migrstions/tools/module.php and to acp_module.php broke it. It doesn't work for me either.
          Hide
          imkingdavid David King added a comment -

          The code that was merged has a small bug in it that I have submitted a patch for. With that patch, I have tested and it works properly.

          Removing a module when purging an extension is messed up, but I have submitted a ticket for that.

          Show
          imkingdavid David King added a comment - The code that was merged has a small bug in it that I have submitted a patch for. With that patch, I have tested and it works properly. Removing a module when purging an extension is messed up, but I have submitted a ticket for that.
          Hide
          Blitze Blitze added a comment -

          Correction: the extension I was using could not have been enabled before being installed. But it worked. So I don't understand the reason for 11381. It caused this problem

          Show
          Blitze Blitze added a comment - Correction: the extension I was using could not have been enabled before being installed. But it worked. So I don't understand the reason for 11381. It caused this problem
          Hide
          EXreaction EXreaction [X] (Inactive) added a comment -

          I could not get it to work without 11381. The way the code was designed I couldn't see how it possibly could have worked.

          Show
          EXreaction EXreaction [X] (Inactive) added a comment - I could not get it to work without 11381. The way the code was designed I couldn't see how it possibly could have worked.

            People

            • Assignee:
              imkingdavid David King
              Reporter:
              Blitze Blitze
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development