Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-11198

AJAX move up/down links not replaced correctly

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: JavaScript / AJAX
    • Labels:
      None

      Description

      If you have 2 items:

      • i1
      • i2

      And move i1 down, the items appear in the following order:

      • i2
      • i1
        however, the move_down link for i2 uses the id of i1, so moving i2 down will not work as intended.

        Issue Links

          Activity

          nickvergessen Joas Schilling added a comment -

          [16:11:14] <nx-> nickvergessen: http://tracker.phpbb.com/browse/PHPBB3-11198 reproduce steps?
          [16:11:21] <nx-> so moving i2 down will not work as intended. - what does that mean?
          [16:11:36] <nickvergessen> go to acp > forums > manage forums
          [16:11:44] <nickvergessen> if you have two forums in the list
          [16:11:48] <nickvergessen> move one down
          [16:12:04] <nickvergessen> and hover the down link of the swapped item
          [16:12:24] <nickvergessen> it will have the same link as the previous link had
          [16:12:29] <nickvergessen> instead of having its own id in the link


            People

            • Assignee:
              nickvergessen Joas Schilling
              Reporter:
              nickvergessen Joas Schilling
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development