Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10909

Update Travis Test Configuration: Travis no longer supports PHP 5.3.2

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.10, 3.1.0-dev
    • Fix Version/s: 3.0.11-RC1, 3.1.0-a1
    • Component/s: Test Suite
    • Labels:
      None

      Description

      As discussed in https://github.com/travis-ci/travis-ci/issues/516#issuecomment-5858003 and implemented in https://github.com/travis-ci/travis-cookbooks/commit/a65154fa570259318ae8a819ae427bad5bbd4ace - the list of PHP versions available on Travis is now: "5.2.17", "5.3.3", "5.3.13", "5.4.3".

      In our .travis.yml we should be using:

      php
        - 5.2
        - 5.3.3
        - 5.3
        - 5.4
      

      On develop 5.2 should be removed.

      We should also consider dropping support for 5.3.2 while dropping support for versions < 5.3.2 in 3.1, as newer Symfony versions require 5.3.3 now since all major linux distributions ship with a version of 5.3.3.

        Attachments

          Activity

            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              naderman Nils Adermann
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: