Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.0.10
    • Fix Version/s: 3.0.12-RC1
    • Component/s: None
    • Labels:
      None

      Description

      As I found out later my mysql server was not running.

      The following output is for when there is no test_config.php:

      athena% PHPBB_TEST_DBMS=mysql PHPBB_NO_COMPOSER_AUTOLOAD=1 PHPBB_AUTOLOAD=~/shared/phpbb_autoload.php PATH=~/opt/php54/bin:$PATH php -d include_path=.:/home/pie/apps/git-phpunit-bundle:/home/pie/apps/git-phpbb3-dependencies ~pie/apps/git-phpunit-bundle/phpunit.php
      PHPUnit @package_version@ by Sebastian Bergmann.
       
      Configuration read from /home/phpdev/test-phpbb/phpunit.xml.dist
       
      I......................EEEEEEEEEEEEEEE......EEEEEEEEEEEEEEEEE   61 / 1321 (  4%)
      EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE  122 / 1321 (  9%)
      EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE..............EEEEEEE......  183 / 1321 ( 13%)
      .............................................................  244 / 1321 ( 18%)
      ..............EEEEEEEEEEEEEEEEEEEEEEEEEEE%                 
      

      Note the output when I specify an invalid driver:

      athena% PHPBB_TEST_DBMS=mysqlx PHPBB_NO_COMPOSER_AUTOLOAD=1 PHPBB_AUTOLOAD=~/shared/phpbb_autoload.php PATH=~/opt/php54/bin:$PATH php -d include_path=.:/home/pie/apps/git-phpunit-bundle:/home/pie/apps/git-phpbb3-dependencies ~pie/apps/git-phpunit-bundle/phpunit.php
      PHPUnit @package_version@ by Sebastian Bergmann.
       
      Configuration read from /home/phpdev/test-phpbb/phpunit.xml.dist
       
      I......................EEEEEEEEEEEEEEE......EEEEEEEEEEEEEEEEE   61 / 1321 (  4%)
      EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE  122 / 1321 (  9%)
      EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE..............EEEEEEE......  183 / 1321 ( 13%)
      .............................................................  244 / 1321 ( 18%)
      ..............EEEEEEEEEEEEEEEEEEEEEEEEEEE
      Fatal error: phpbb_database_test_case::new_dbal(): Failed opening required '/home/phpdev/test-phpbb/tests/test_framework/../../phpBB/includes/db/mysqlx.php' (include_path='/home/pie/apps/git-phpunit-bundle:.:/home/pie/apps/git-phpunit-bundle:/home/pie/apps/git-phpbb3-dependencies') in /home/phpdev/test-phpbb/tests/test_framework/phpbb_database_test_case.php on line 81
      

      Seems to die in the same place but with a message.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Oleg Oleg [X] (Inactive)
                Reporter:
                Oleg Oleg [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: