Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10694

Update notification in ACP (Olympus) for increase of minimum PHP version to 5.3.2

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.10, 3.1.0-dev
    • Fix Version/s: 3.0.11-RC1
    • Component/s: None
    • Labels:
      None

      Description

      When the minimum PHP version for Ascraeus was increased to PHP 5.2, a notice was added to includes/acp/acp_main.php to notify the admin if their PHP version was too low for the eventual upgrade.

      This needs to be done again since the minimum PHP version for Ascraeus is again being changed to PHP 5.3.2

        Issue Links

          Activity

          Hide
          rxu Ruslan Uzdenov added a comment -

          	'PHP_VERSION_OLD'	=> 'The version of PHP on this server will no longer be supported by future versions of phpBB. %sDetails%s',
          

          This notification is confusing users now.
          First, they aren't informed what future versions will no longer support their current PHP installed, and assume it can be right the next 3.0 version.
          Second, they aren't informed what version of PHP they have to upgrade to. and when they should do it.
          As a consequence, they're asking on support board and hammering their HSPs with upgrade requests (where they have no idea what to upgrade to what).
          As for the link to the minimal PHP version announcement, they either simply don't follow it or can't understand (language barrier etc).

          I suggest the language variable to be adjusted to provide required information for users to keep them calm and informed.

          Show
          rxu Ruslan Uzdenov added a comment - 'PHP_VERSION_OLD' => 'The version of PHP on this server will no longer be supported by future versions of phpBB. %sDetails%s', This notification is confusing users now. First, they aren't informed what future versions will no longer support their current PHP installed, and assume it can be right the next 3.0 version. Second, they aren't informed what version of PHP they have to upgrade to. and when they should do it. As a consequence, they're asking on support board and hammering their HSPs with upgrade requests (where they have no idea what to upgrade to what). As for the link to the minimal PHP version announcement, they either simply don't follow it or can't understand (language barrier etc). I suggest the language variable to be adjusted to provide required information for users to keep them calm and informed.
          Hide
          bantu Andreas Fischer added a comment -

          I tend to agree. Please create a new ticket for putting the info into phpBB instead of using a link. We should have noticed this earlier.

          Show
          bantu Andreas Fischer added a comment - I tend to agree. Please create a new ticket for putting the info into phpBB instead of using a link. We should have noticed this earlier.

            People

            • Assignee:
              bantu Andreas Fischer
              Reporter:
              imkingdavid David King
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development