Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10628

http:// prepended to "www." urls (but not reflected in preview)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.12
    • Fix Version/s: 3.2.0-b1
    • Component/s: Posting
    • Labels:
      None

      Description

      See also http://www.phpbb.com/community/viewtopic.php?f=46&t=2150034

      On typing an URL such as 'www.example.com', the preview rendering of the text contains a link saying 'www.example.com' (as expected) but the edit text below the preview has been changed to say 'http://www.example.com'.
      In other words, the edit text has had 'http://' prepended to the URL, but the changes aren't reflected until the next Preview.

      If Submit is clicked without the 'http://' ,then the final result (as with the preview rendering) doesn't contain the 'http://' either.

      Either way the link is clickable and works as expected, but the text has been altered, which may not be desirable.

      The same thing happens with www links in url tags.

        Attachments

          Activity

            People

            • Assignee:
              Marc Marc
              Reporter:
              mfearnley mfearnley
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: