Details

    • Type: Task
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: Test Suite
    • Labels:
      None

      Description

      We should have a way to define functional tests.

        Issue Links

          Activity

          Hide
          naderman Nils Adermann added a comment -

          Fails on PHP 5.2

          Show
          naderman Nils Adermann added a comment - Fails on PHP 5.2
          Hide
          Oleg Oleg [X] (Inactive) added a comment -

          Was documentation written for these changes?

          Show
          Oleg Oleg [X] (Inactive) added a comment - Was documentation written for these changes?
          Show
          igorw Igor Wiedler [X] (Inactive) added a comment - Yes: http://wiki.phpbb.com/Writing_Functional_Tests
          Hide
          Oleg Oleg [X] (Inactive) added a comment -

          This apparently broke the tests entirely for me:

          athena% php -d include_path=.:/home/pie/apps/git-phpunit-bundle ~pie/apps/git-phpunit-bundle/phpunit.php --verbose  
           
          Fatal error: Could not convert the script from the detected encoding "UTF-32LE" to a compatible encoding in /home/phpdev/test-phpbb/tests/test_framework/phpbb_functional_test_case.php on line 10
           
          athena% php -v
          PHP 5.3.8 with Suhosin-Patch (cli) (built: Sep 14 2011 02:57:18) 
          Copyright (c) 1997-2011 The PHP Group
          Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
           
          athena%  php -d include_path=.:/home/pie/apps/git-phpunit-bundle ~pie/apps/git-phpunit-bundle/phpunit.php  --version
          PHPUnit @package_version@ by Sebastian Bergmann.
          
          

          Show
          Oleg Oleg [X] (Inactive) added a comment - This apparently broke the tests entirely for me: athena% php -d include_path=.:/home/pie/apps/git-phpunit-bundle ~pie/apps/git-phpunit-bundle/phpunit.php --verbose   Fatal error: Could not convert the script from the detected encoding "UTF-32LE" to a compatible encoding in /home/phpdev/test-phpbb/tests/test_framework/phpbb_functional_test_case.php on line 10   athena% php -v PHP 5.3.8 with Suhosin-Patch (cli) (built: Sep 14 2011 02:57:18) Copyright (c) 1997-2011 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies   athena% php -d include_path=.:/home/pie/apps/git-phpunit-bundle ~pie/apps/git-phpunit-bundle/phpunit.php --version PHPUnit @package_version@ by Sebastian Bergmann.

            People

            • Assignee:
              naderman Nils Adermann
              Reporter:
              igorw Igor Wiedler [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development