Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10389

JSON extension should be checked in the installer

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0-dev
    • Fix Version/s: 3.1.0-a1
    • Component/s: Installation system
    • Labels:
      None

      Description

      The JSON extension must be available to provide the json_encode() and json_decode() functions. Also the PHP version requirement should be bumped to 5.2.1 to permit JSON encoding of basic types. See: http://uk3.php.net/manual/en/function.json-encode.php#refsect1-function.json-encode-changelog

        Issue Links

          Activity

          Hide
          ToonArmy Chris Smith added a comment -

          PHP documentation is incorrect per https://bugs.php.net/bug.php?id=55786 we shouldn't need to increase the required version to 5.2.1.

          Show
          ToonArmy Chris Smith added a comment - PHP documentation is incorrect per https://bugs.php.net/bug.php?id=55786 we shouldn't need to increase the required version to 5.2.1.
          Hide
          ToonArmy Chris Smith added a comment -

          Makes sense to wait until the environment checks are finished.

          Show
          ToonArmy Chris Smith added a comment - Makes sense to wait until the environment checks are finished.
          Hide
          unknown bliss unknown bliss added a comment -

          Will this be something required or optional? If optional then other things will need adjusting to enable/disable whether it is available or not.

          Show
          unknown bliss unknown bliss added a comment - Will this be something required or optional? If optional then other things will need adjusting to enable/disable whether it is available or not.
          Hide
          rxu Ruslan Uzdenov added a comment -
          Show
          rxu Ruslan Uzdenov added a comment - As per naderman, phpBB should require json: http://area51.phpbb.com/phpBB/viewtopic.php?f=84&t=41208&p=232973#p232973
          Hide
          unknown bliss unknown bliss added a comment -

          Thats good. Thanks.

          Show
          unknown bliss unknown bliss added a comment - Thats good. Thanks.
          Hide
          brunoais brunoais added a comment -

          Version check, etc... is now at 5.3.2. Is this bug still valid?

          Show
          brunoais brunoais added a comment - Version check, etc... is now at 5.3.2. Is this bug still valid?
          Hide
          nickvergessen Joas Schilling added a comment -

          brunoais is right I guess? at least from how I read the docs it's included in PHP 5 >= 5.2.0

          Show
          nickvergessen Joas Schilling added a comment - brunoais is right I guess? at least from how I read the docs it's included in PHP 5 >= 5.2.0
          Hide
          EXreaction EXreaction [X] (Inactive) added a comment -

          Docs say: PHP 5 >= 5.2.0, PECL json >= 1.2.0.

          Both included as of 5.3.0 at least. Closing this bug.

          Show
          EXreaction EXreaction [X] (Inactive) added a comment - Docs say: PHP 5 >= 5.2.0, PECL json >= 1.2.0. Both included as of 5.3.0 at least. Closing this bug.

            People

            • Assignee:
              EXreaction EXreaction [X] (Inactive)
              Reporter:
              ToonArmy Chris Smith
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development