Uploaded image for project: 'phpBB3'
  1. phpBB3
  2. PHPBB3-10219

Inappropriate character in web.config file

    Details

    • Type: Bug
    • Status: Unverified Fix
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.8, 3.0.9-RC1
    • Fix Version/s: 3.0.9-RC2
    • Component/s: None
    • Labels:
      None

      Description

      In web.config file, there is an innappropriate character on line 9:

      					<add segment="store" />­-
      

      (last character)

        Activity

        Hide
        igorw Igor Wiedler [X] (Inactive) added a comment -

        Interesting. The source file does not contain that character, but the 3.0.8 release does. This is possibly build script related.

        Show
        igorw Igor Wiedler [X] (Inactive) added a comment - Interesting. The source file does not contain that character, but the 3.0.8 release does. This is possibly build script related.
        Hide
        carlino1994 carlino1994 added a comment - - edited

        I noticed that with my editor, if I do a copy/paste of the line, the character is not copied.

        I think the problem is the file charset (UTF-8 with no BOM).
        Try changing the file charset with your editor, and see the result.

        Show
        carlino1994 carlino1994 added a comment - - edited I noticed that with my editor, if I do a copy/paste of the line, the character is not copied. I think the problem is the file charset (UTF-8 with no BOM). Try changing the file charset with your editor, and see the result.
        Hide
        AdamR Adam Reyher added a comment -

        The character is definitely there in the source file in develop-olympus: https://raw.github.com/phpbb/phpbb3/develop-olympus/phpBB/web.config

        It appears as if it's always been there:
        https://raw.github.com/phpbb/phpbb3/8612fc23d4d7ca90ea80e5a12e7bd51ed315e0dd/phpBB/web.config

        Interesting that I never noticed this before.

        Show
        AdamR Adam Reyher added a comment - The character is definitely there in the source file in develop-olympus: https://raw.github.com/phpbb/phpbb3/develop-olympus/phpBB/web.config It appears as if it's always been there: https://raw.github.com/phpbb/phpbb3/8612fc23d4d7ca90ea80e5a12e7bd51ed315e0dd/phpBB/web.config Interesting that I never noticed this before.
        Hide
        bantu Andreas Fischer added a comment -

        Good catch.

        Show
        bantu Andreas Fischer added a comment - Good catch.

          People

          • Assignee:
            bantu Andreas Fischer
            Reporter:
            carlino1994 carlino1994
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development